Mountain Lion 10.8.1 installed on my hackintosh

As I wrote earlier, I’ve waited for Apple to release the first update for Mountain Lion before I’m upgrading from Lion. Since I’m going to be upgrading my hackintosh, I was also waiting for MultiBeast to be updated.

Now that both of these criteria are met, I decided to install Mountain Lion on my hackintosh. You can read about my hardware here, but to give a quick recap:

MOBO: GIGABYTE GA-Z68MX-UD2H-B3 Z68 S-1155 M-ATX (BIOS: F13)
CPU: INTEL CORE I5 2500K 3.30GHZ 6MB S-1155
RAM: KINGSTON DDR3 HYPERX 8GB 1600MHZ CL9 (2X4GB)
GFX: XFX RADEON HD6870 1GB GDDR5 PCI-E DVI/HDMI/DP (HD-687A-ZHFC)
CASE: FRACTAL DESIGN DEFINE MINI MINITOWER M-ATX BLACK
PSU: CORSAIR TX 650W V2
HDD: One I had lying around (60GB from a PS3), I use a Kingston HyperX SSD 120GB as my main boot drive for Windows 8 and another 500GB HDD for storage + NAS.

I already had Lion running flawless, so I hoped the same would be true for Mountain Lion. So here goes:

I bought Mountain Lion from the Mac App Store, which downloaded to Applications. Copied it to my NAS for backup.

I then downloaded UniBeast and ran it to make an USB (must be over 5GB) for installing Mountain Lion to any Intel-based computer.

Since setup doesn’t support the Radeon 6xxx series, I had two options:

1) Remove the graphics card (or pull out the PCI-E power cables) and use either the built in graphics in Sandy/Ivy Bridge or another card.

2) Delete the ATI6000Controller.kext from the USB.

I tried both methods and they both worked.

The kext (driver) is located in System/Library/Extensions (S/L/E) which is a hidden location. To show hidden files you have to run a command from Terminal.

defaults write com.apple.Finder AppleShowAllFiles YES

Then restart Finder by pressing Alt while right-clicking Finder in the Dock and choose Relaunch.

Copy the ATI6000Controller.kext for backup before deleting it, because you’re installing it later.

On the hackintosh be sure to enter BIOS and load Optimized defaults. Double-check to see that:

SATA=ACHI

HPET=64 bit

ACPI= S3 (Suspend to RAM)

You’re now ready to boot from the USB. Just follow the UniBeast guide.

The only thing I had to do was to use GraphicsEnabler=No:

At the Chimera boot screen, just start typing.

When setup restarts, you’ll have to do this again. But this time choose to start from the internal drive (Mountain Lion if you followed the UniBeast guide). Then finish setup.

When you’re at the Mountain Lion desktop, copy ATI6000Controller.kext to it. Then download KexBeast, unzip it to the desktop and run it. You have to enable 3rd party apps to run from System Preferences/Security first. Update: Or you can right-click and chose Open. KextBeast will install the driver back to S/L/E. Then restart and boot from the USB one last time. Choose the internal drive again. Remove the USB and download MultiBeast and the correct DSDT file for your motherboard. If you have updated your Gigabyte motherboard to UEFI, you don’t need a DSDT.

Put both files on the dekstop and run MultiBeast. Check the following:

UserDSDT or DSDT-Free Installation

ALC 889 under audio driver

Lnx2Mac´s RealTekRTL81xx Ethernet  under network driver

Sandy Bridge Core i5 under Customization >> SSDT Options

Note: This is just the necessary drivers for basic operation.

I had a problem booting Mountain Lion after running MultiBeast. The standard grey Apple logo screen would get an forbidden sign over the Apple.

Booting with -v (for verbose output) showed that the system hang on “Still waiting for root device”. A search in the forums gave me different things to try out, among them trying another SATA-port and run a script to insert a pause for detecting devices. I installed Mountain Lion several times and successfully booted many times via the UniBeast USB (before running MultiBeast). Each time I ran  MultiBeast and restarted, it hang. I tried booting with different flags, and finally found out that using -f (ignore caches) worked.

So I edited my boot.plist in the Extras folder on the internal drive. I set UseKernelCache to No.

Now my hackintosh boots up without the USB and without me interfering.

Sound and ethernet works. Sleep works. I have full screen resolution (1680×1050) and GPU acceleration. Oh the joy!

Leave a Reply